PHPのバージョンが古いと危険?最新版にアップデートしよう!

当サイトはエックスサーバーで運営しているんですが、つい最近、そのエックスサーバーから、こんなメールが届きました。

平素はエックスサーバーをご利用いただき、誠にありがとうございます。

この度エックスサーバーでは、推奨するPHPバージョンを「7.0」に変更いたします。

引き続きPHP 5.6 もご利用いただけますが、今後はPHP 7.0 のご利用を推奨いたします。

また、新規に追加設定されるドメインにおいて、初期状態でご利用いただけるPHPのバージョンを「7.0」に変更いたします。

…ん?たまにこんな感じのメールがきますが、今回はなんだか重々しい気が。。

WordPressのバージョンならいつもすぐに最新にしてますが、PHPのバージョンはノータッチでした。。

PHPのバージョンアップは手動

というのも、PHPは、WordPressと同じように自分でバージョンアップする必要があるんです。

これまで、なぜかよくわかりませんが、PHPのバージョンは自動でバージョンアップされるもんだと思ってました…壮絶な勘違い乙。。

今回、バージョンアップを促されたのは「PHP7.0」。かなり前からサポートされていたバージョンでしたが、レベルが「推奨」に変わったようです。

PHPのバージョンが古いとどうなるの?

というか、そもそも、PHPのバージョンが古いとどうなるんでしょうか?

エックスサーバーの管理画面を見る限り、古いバージョンはサポート対象外になるようですが、何かマズイことでもあるんでしょうか?

これに関して、いくつか情報を集めてみたんですが、結論から言うと「ヤバイ」です。

WordPressの日本語ローカルサイト(公式)でも、その危険性がアナウンスされていました。

古い PHP や MySQL しか利用できないレガシーな環境でも、PHP 5.2.4 以上、かつ MySQL 5.0 以上であれば WordPress は動作しますが、公式サポートは終了しており、サイトがセキュリティの脆弱性にさらされる危険があります。

引用:WordPress 日本語ローカルサイト

また、PHPが上手く動作しないこともあるそうです。

PHPのバージョンを上げる方法(エックスサーバー)

ということで、PHPのバージョンアップ初挑戦!さぞかし難しいんだろうな〜!

まずは、サーバーパネルにアクセスして、「PHP Ver.切替」をクリック。

 

推奨されているバージョンを選択し、「バージョンを切り替える」をクリック。

 

…あれ?以上で終了みたいです!めっちゃ簡単!

不具合はある?

WordPressはPHPで動いているので、「PHPのバージョンが変わった影響でサイトが真っ白になったりしたらどうしよう」と心配していたんですが…まったく問題ありませんでした。

まぁ、エックスサーバーが「推奨」したバージョンアップなので、そこまで不安になる必要はないかもしれませんね。

そして、万が一不具合があった場合は、エックスサーバー側でバージョンを元に戻すこともできます。前のバージョンもしばらくはサポートするらしいですよ:D

バージョンアップ後の変化は?

エックスサーバーの説明によると、最新バージョンにすることで処理速度が2倍になるそうですが、正直、違いはよくわかりませんでした。

PHP7 は、PHP5 に比べ2倍以上の実行速度を誇り、メモリ使用量が大幅に改善されたPHPの最新バージョンです。

PHP7 をご利用いただくことにより、高速なウェブサイトを運用することが可能となります。

引用:エックスサーバー

とりあえず、当サイトでは、劇的に表示速度が速くなったりはしませんでした。

まとめ

  • WordPressのバージョンは最新
  • プラグインでセキュリティ強化

でも、PHPのバージョンが古くてセキュリティぼろぼろ…みたいなこともあり得るので、バージョンアップが「推奨」になったら早めに対応した方が良さそうですね。

まだ対応していない方はお早めに!(`・ω・´)ゞ

キャリアアップ ブラックな求人広告を見分けてホワイト企業に応募する方法。

キャリアアップ 給料が安い?残業が多い?仕事を辞めたい20代の転職ハック。

キャリアアップ 初めての就職・転職が不安な方におすすめの転職エージェント

カテゴリーWordPress豆知識

この記事が良かったらいいね!最新情報が届きます!

この記事を書いた人 :

WEBメディア「MORIAWASE」の運営者。求人広告会社の元施設長で、趣味は音楽制作(DTM)。育児に奮闘中です!